sábado, 7 de noviembre de 2020

Bajar la versión de Gradle

Después de la actualización de Android Studio a versión 4.1, cada vez que abría uno de mis proyectos me recomendaba que actualizara Plugin. Yo muy obediente los actualizaba y a partir de ahí empezaban los problemas.

Cada vez que ejecutaba el proyecto, aparecía el siguiente error:

A problem was found with the configuration of task ':app:processDebugManifest' (type 'ProcessMultiApkApplicationManifest').

> File 'D:\ProyectosAndroidStudio\CanariasVistaApp\app\build\intermediates\merged_manifest\debug\out\AndroidManifest.xml' specified for property 'mainMergedManifest' does not exist.

Después de mucho buscar y dejar pasar una semana, he encontrado la solución en stackoverflow como no. Básicamente consiste en bajar la versión de Android Gradle Plugin desde la 4.1.0 a la 4.0.2 y la versión de Gradle  desde la 6.5 a la 6.4.1

Para ello, en Android Studio y para cada proyecto donde haya actualizado el Plugin, has de ir a File - Project Structure - Project y seleccionar las versiones indicadas.


Las versiones por defecto serían las siguientes:

La nueva configuración sería:

Hacemos click en OK y todo y despu.es de un rato todo vuelve a funcionar correctamente. Está claro que hay algún error o incompatibilidad con las nuevas versiones por lo que espero que se solucione pronto.


3 comentarios:

  1. Me alegraste el día, pasaba por el mismo problema aunque es no pasa con todos los proyectos antiguos. Gracias me vino estupendamente una solución temporal.

    ResponderEliminar
  2. Sigue publicando más soluciones así. Gracias

    ResponderEliminar